[Dibbler] dibbler-client does not start (Lubuntu 14.04)

Schneider, Simon (NSN - DE/Dusseldorf) simon.schneider at nsn.com
Tue Jan 20 10:49:27 CET 2015


Hi,
I managed to solve the issue with Lubuntu 14.04 by getting the latest Snapshot and installing the client from that.

(I didn't upgrade the dibbler-server version)

DHCPv6 now works between my VMs!

Thanks for your support,
Best regards, Simon

-----Original Message-----
From: Dibbler [mailto:dibbler-bounces at klub.com.pl] On Behalf Of ext Tomasz Mrugalski
Sent: Monday, January 19, 2015 6:29 PM
To: dibbler at klub.com.pl
Subject: Re: [Dibbler] dibbler-client does not start (Lubuntu 14.04)

On 19.01.2015 14:00, Schneider, Simon (NSN - DE/Dusseldorf) wrote:
> Hi,
> Ok, I used "start" so far. "run" gives more info :-)
> 
> Log file is attached. Can you please check it? Thanks a lot!
Hmmm, seems like a segfault. That's definitely a bug.

You're using 1.0.0RC1, please try 1.0.0. I don't know what caused the
problem yet, but there's a chance that your issue has been fixed.
Or even better, the latest from git.

If the problem persists, please do the following:

1. recompile dibbler with --enable-debug
2. start gdb
3. type: file dibbler-client (this will load the binary)
4. type: r run (this will run dibbler-client)
5. hopefully it will crash as before
6. type: bt (backtrace)

Send me the result of this bt command. It will show the exact place
where the code failed. Hopefully that will be sufficient. If not, I'll
be asking you to send me the the core dump and your binary. To get those:

1. make sure dibbler can dump core (ulimit -c 999999999)
2. run dibbler
3. It will segfault and should dump core
4. send me your dibbler-client binary and the dumped core

Please send me that info off-the list. We don't want to send all that
stuff to all those people on the list.

Tomek


_______________________________________________
http://klub.com.pl/cgi-bin/mailman/listinfo/dibbler


More information about the Dibbler mailing list