[Dibbler] Problems assigning DNS on ppp interface

Steve Phillips steve at focb.co.nz
Fri Mar 16 01:13:39 CET 2012


Hey there,

I am in the process of setting up a VPN server to allow clients to be 
assigned both an IPv4 address as well as a global /64 IPv6 address, this 
all worth with varying levels of reliability, however, trying to assign 
IPv6 DNS addresses has gotten me completely stumped.

The server is a linux box running dibbler-server 0.8.2
The client is a windows 7
the VPN client is just the built in vpn adaptor found with windows and 
set to pptp mode

I started off with the stateless option and just trying to pass back the 
DNS server address.

log-level 8
log-mode syslog
stateless
iface ppp0 {
   option dns-server 2001:49f0:1025::10
   option domain focb.co.nz
   option lifetime 500
}

However, this didn't seem to work, so I tried to setup stateful 
allocation by adding a class

log-level 8
log-mode syslog
iface ppp0 {
   class {
     pool 2001:49f0:1025:1::10-2001:49f0:1025:1::100
   }
   option dns-server 2001:49f0:1025::10
   option domain focb.co.nz
   option lifetime 500
}

This also proved fruitless, so I tried with a prefix delegation

log-level 8
log-mode syslog
iface ppp0 {
   pd-class {
     pd-pool 2001:49f0:1025:1::/64
     pd-length 64
     T1 11111
     T2 22222
   }
   option dns-server 2001:49f0:1025::10
   option domain focb.co.nz
   option lifetime 500
}

And still nothing.

It appears that no DHCPv6 traffic is even happening on the link once it 
comes up, but it's difficult to see the initial negotiations due to the 
dynamic nature of the link (tcpdump doesn't like to operate on an 
interface that isn't there :-) )

I tried to tell windows to /renew6 the tunnel interface, but got an 
error stating "the operation failed as there is no adapter in the state 
permissible" when using the interface ID to force a renewal.

I suspect that windows is simply not trying to send an 
INFORMATION_REQUEST message on the ppp link (or indeed, an other type of 
dhcpv6 message) but am not too sure why this would be.

 From reading back through the archives, it seems that a few people HAVE 
gotten something similar to work (VPN server, radvd to assign a prefix 
via RA and then DNS over ppp0 with dibbler ) - what did you do on the 
windows client side to get this working ?

Either that, or is there something in my config that is wrong ?

Please help, I'm busy going hairless here :-)

-- 
Steve.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 3739 bytes
Desc: S/MIME Cryptographic Signature
URL: <http://klub.com.pl/pipermail/dibbler/attachments/20120316/31f64287/attachment.bin>


More information about the Dibbler mailing list