[Dibbler] Relay Configuration Problem

Tomasz Mrugalski thomson at klub.com.pl
Tue May 3 18:18:59 CEST 2005


On Tue, 3 May 2005 somebody known as Jimmy Ott wrote:

> the client now sends a dhcpv6 solicitation message, the relay receive
> this, and try to relay to fd00:0:0:3::a, but nothing happens, i also
> don't see a packet when i trace with ethereal besides the IPv6
> Solicitation Packet from the Client. the client try in different
> intervals, as specified, to get an ip via the relay....
>
> on the top of the relay log i see something very strange:
> 32:30 Notice    Creating srv unicast (fe80::200:39ff:fe24:d1e1) socket
> on the Local Area Connection/5 interface.
> 32:30 Notice    Creating clnt multicast (ff02::1:2) socket on the Local
> Area Connection/5 interface.
>
> does the relay try to reach the routeable multicast address
> fd00:0:0:3::a via it's link-local address????
Oops. I have checked it and found an intersting comment in the code:

RelTransMgr.cpp:82: // FIXME: global or site-scoped address should be used

Well, that explains it. This is definetly a Dibbler bug. I have added it 
to the bugzilla (see bug #113). I have fixed it in no time. I'm compiling 
new CVS snapshot right now. Linux binaries and source version will be 
available in an hour or so. I'll try to prepare Windows binaries too, but 
this might take some time.

> on the server, i'm using the cvs version.
> attached are the configs and the logs.
Thanks. Those log files were really helpful.

Cheers,

-- 
Tomasz Mrugalski,              |"Computers are the most fun you can have with |
thomson(at)klub(dot)com(dot)pl | anything that isn't breathing."              |
                                |                                 Bruce Walker |


More information about the Dibbler mailing list